NeoFinder 6.2.1 certified for Mavericks

NeoFinder Icon 128 px Alpha


NeoFinder 6.2.1 now certified for Mavericks!

NeoFinder 6.2.1 has been tested and works fine in the new Mac OS X 10.9, aka Mavericks.

Of course, as always, we suggest to wait until at least 10.9.2 before updating
productive systems to the new Mac OS X version.